
 

    BUUTHILL     
GETTING STARTED 

Revision 33 
 

 
 

By: Brian Anderson 



 2 

 

INTRODUCTION .................................................................................................................................................. 3 

TECHNICAL ASSISTANCE ................................................................................................................................ 3 

INSTALLATION ................................................................................................................................................... 3 

Problems that may appear:.............................................................................................................................................. 3 

STARTING THE PROGRAM ............................................................................................................................... 3 

USING THE PROGRAM ...................................................................................................................................... 5 

SHORTCUTS AND CONVENTIONS ........................................................................................................................... 5 

HELP ................................................................................................................................................................................. 5 

MAIN FORMS ....................................................................................................................................................... 5 

REPORT FORM .............................................................................................................................................................. 6 
SELECT TABLE ............................................................................................................................................................................. 6 
CEMETERY MAP ........................................................................................................................................................................... 6 

LOT FORM....................................................................................................................................................................... 8 
OWNER SECTION ......................................................................................................................................................................... 9 
BURIAL SECTION ......................................................................................................................................................................... 9 
COMMENTS SECTION ................................................................................................................................................................. 9 
LOT MAP SECTION ....................................................................................................................................................................... 9 

TUTORIAL........................................................................................................................................................... 10 

FINDING RECORDS IN THE REPORT FORM ....................................................................................................... 10 
Quick name find. ............................................................................................................................................................................ 10 
Find records with other find criteria. .............................................................................................................................................. 10 
Select all records with select criteria. ............................................................................................................................................. 10 
Redisplay all records into the select table. ..................................................................................................................................... 10 

FINDING RECORDS/LOTS IN THE LOT FORM ................................................................................................... 10 

SORTING RECORDS ................................................................................................................................................... 11 

UPDATING RECORDS ................................................................................................................................................ 11 
Record update. ................................................................................................................................................................................ 11 
Undo ............................................................................................................................................................................................... 11 
Record add...................................................................................................................................................................................... 11 
Record delete .................................................................................................................................................................................. 11 

PRINTING ...................................................................................................................................................................... 12 
Printing the select table .................................................................................................................................................................. 12 
Printing the lot form ....................................................................................................................................................................... 12 
Printing maps .................................................................................................................................................................................. 12 

MAPS/WALL CHARTS ....................................................................................................................................... 13 
MAP print prevue form .................................................................................................................................................................. 13 
Printing the cemetery map .............................................................................................................................................................. 14 

MISCELLANEOUS ....................................................................................................................................................... 15 
Making a new database .................................................................................................................................................................. 15 
Backing up your database. .............................................................................................................................................................. 15 
Restoring your database. ................................................................................................................................................................ 15 
MAKING A SHORTCUT .............................................................................................................................................................. 16 
OPENING A DATABASE WITH THE SHORTCUT .................................................................................................................. 16 

 



 3 

INTRODUCTION 
BUUTHILL is designed to retain cemetery records and a cemetery map.  Following are some of the capabilities: 

1.  Display records with an associated lot locator map. 

2.  Display records for complete lots on a single page with a lot locator map. 

3.  Display records in any sequence desired. 

4.  Allows and displays pictures of graves, lots , obituaries and monuments. 

5.  Extensive error checking. 

6.  Search and find functions for the records. 

7.  Backup and restore of the database. 

8.  Extensive help file. 

9.  Manual and program to allow users to define their own cemetery map 

10. Ability to print lists in any order desired 

11. Ability to print the lot forms as they are displayed. 

12. Ability to print maps of the whole cemetery or any part of it at any size with options to embed names and add a name index. 

13 Ability to maintain and display pictures and obituaries. 

14 Ability to print address labels. 

15 Web Publishing. 

 

BUUTHILL runs under all windows systems. 

 

WARNING 

This manual is designed only to show you how to install and understand and navigate thru the program.  Only the major features 

are covered here.  Once you have become familiar with those things covered here, you should refer to the help file for all features 

available on each form. 

TECHNICAL ASSISTANCE 
Contact: Marvin Topper 

E-mail: marv@buuthill.com 

Tel: 612 245-2755 

Address 36955 Palm St NW 

Stanchfield, MN  55080 

INSTALLATION 

WARNING 1 

 If you have already downloaded and installed the program from the BUUTHILL home site, you should ignore 

the rest of the install section.  Also, if you are running level 25 or lower contact the Buuthill administration as 

there are some compatibility upgrades needed. 

 

WARNING 2 

  If you currently have a version of BUUTHILL installed, uninstall it before installing this version. 
 

Go to buuthill.com on the web.  Go to the download menu and follow instructions..  Answer “Run” to the “Run or Save” question. 

 

A ZIP file will be downloaded and you will get instructions to unzip.  At that time , the installation begins.. 

 

The next screen will tell you to continue by hitting the big button on the left. Do that. 

 

The next screen will show you a list of program groups with BUUTHILL highlighted as the default.  Leave it as is and hit continue. 

 

The program now starts copying files.  If there are no problems this will finish with no incident.  

 

The next screen will say: Installation completed successfully.  Just hit OK and you are done. 

Problems that may appear: 

1. A message box warning that one or more files on your computer are more current than the ones being installed.  You will be asked if you want to 

keep those on your computer.  You should press the button that says, Yes. 

 

2.  A message box saying there was a fatal error.  I do not know what happens or why but in the 2 incidents where it happened, I just hit ignore and 

the install finished ok. 

STARTING THE PROGRAM 
Hit the Start button on the lower left corner of your desktop and select program files from the resulting menus. 
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Select the entry BUUTHILL.  Another submenu appears with BUUTHILL as the only entry in it.  Click this entry to start the program 

 

A file open dialog box will appear showing the databases you may open.  If this is the first install of BUUTHILL on this computer, the only file 

available will be sample.cmf. In any case select that one and hit open.  The sample database will be opened and you will see a picture of a cemetery. 
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USING THE PROGRAM 

SHORTCUTS AND CONVENTIONS 

This manual doesn’t have many shortcuts or conventions but the following are used: 

 

Rather than say “Click the word Database” on the menu bar and then click the word Open on the menu that drops down this manual says Choose 

Database>Open.  This method saves time and space.  The underlined letters you see in the steps are the same ones you find in Windows programs.  

They indicate that you can press the Alt key along with the underlined letter(s) to get the same result.  You hold down the alt key while hitting each 

letter in turn(Example Alt+DO).  This might be handy if the mouse breaks. 

 

Another way to get to most of the more used menu items in Windows is to use the specified shortcut key.  It can be just a function key such as F3 or 

a combination of the Ctrl key along with a letter such as Ctrl+O to open a database.  To determine what the shortcut for a menu is, go to the menu 

item and look to the right of the menu item.  If a shortcut exists, it is listed there. 

 

Click anywhere on the opening screen when just the cemetery is showing and a list of the most common shortcuts is displayed. 

HELP 

An extensive help file is provided.  It can be accessed from the opening form by hitting F2 or choosing Help>Program Overview. It is recommended 

that you familiarize yourself with the program by perusing the help file and trying things out with the sample database. 

 

You may also get help information for any form that you are currently on by hitting the F1 key. 

 

If you are unfamiliar with the windows help system, you can learn the basics needed by choosing Help>Using help from the opening or 

report window 

 

MAIN FORMS 
The 2 primary forms are the report and lot forms.  You will spend most of your time here.  You may toggle from one to the other by hitting F5 for the 

lot form and F6 for the report form.  If you exit or x off the lot window, control also returns to the report window.  If you exit or X off the report 

form, the program will terminate. 
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REPORT FORM 

 
 

This window has 2 main parts.  The top half is called a select table and the bottom half is a map of the cemetery. 

SELECT TABLE 

This table contains all records from the database, which were last selected.  When the program starts all records in the database appear here.  

Selection is done via the Find menu. 

 

To find out about the type of data stored here, go to the help file (F2) then  Table fields. 

 

Use the Edit and Options menus for controlling what is displayed here and how it is displayed. 

 

Use the “V” button in the upper left corner to switch between owner, burial and all fields. 

 

Use the “+” and “-“ buttons in the upper left corner to increase or decrease the font size of the table. 

 

Any record, which appears in a record in the select report, is highlighted in blue in the cemetery map below.  There will be a red /ellipse on the lot in 

the map, depicting the lot, which contains the currently highlighted record in the select report. 

CEMETERY MAP 

You may change the currently selected lot by left clicking the mouse over a line in the select report.  This will cause the red circle/ellipse to move to 

the lot which contains that record. 

 

If you hit the F5 button the lot form will appear displaying all of the info about the lot. 

 

If you left click on this map the lot form will also be displayed but the lot info displayed will be the one under the cursor at the time you clicked it. 

 



 7 

Another way to get to the lot form with the desired lot displayed is to press the Ctrl+L keys.  An input box will appear asking you to enter the desired 

lot.  Upon hitting the OK button, the lot form will appear with that lot displayed. 

 

 Note:  If you want to return to the report form from the lot form hit the F6 button. 
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LOT FORM 
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OWNER SECTION 

This is the upper section of the window (Above the first black horizontal separator bar) 

It displays the lot id in the upper right hand corner and displays owner, reserved and contact type records for the lot. 

 

To find out about the type of data stored here, go to the help file (F2) then Lot window owner section. 

 

Updating of these records is done by left clicking on the record which you wish to change.  Adding records is accomplished by left clicking on the 

last line which is blank. 

BURIAL SECTION 

This is the middle left section of the window.  It displays all burial records for the plot.  Updating of these records is done by left clicking on the 

record which you wish to change.  Adding records is accomplished by left clicking on the last line which is blank. 

COMMENTS SECTION 

This section is on the bottom part of the form and allows you to enter comments about the lot, which cannot be entered in the fields.   Several 

thousand characters can be entered.  If more are entered than will fit in the area, a horizontal scroll bar will appear on the right, which you can use to 

view all of the information 

 

Right clicking on this text area will present a menu that allows the editing commands: 

LOT MAP SECTION 

This section is on the right side of the form and has three parts: 

LOWER   Displays the current lot map with the owners and buried people entered for each grave.  

UPPER RIGHT Will have the current block map with all of the lots in that block displayed.  It will also have a red ellipse in the lot that is 

currently on display. 

UPPER LEFT   Shows all of the blocks in the cemetery and will have a red ellipse on the block that contains the current lot. 

 

Whenever you select a lot, these will change to reflect the position of that lot in the cemetery. 

 

If your cemetery is large and you have to make multiple sections of blocks to define it, this format changes a bit. 

From the lot form hit help for more details. 

 

If you left click on a lot in the block map, that lot will be displayed.   If you left click on the cemetery map, the closest lot to that area will be 

displayed and the block map will be changed to reflect that position 
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TUTORIAL 
This section will walk you through the main tasks needed to use this program by using examples.  To examine more details about each task, you 

should use the help file by hitting F1 or the HELP button when you are in each form for more details. 

 

This tutorial assumes you are working with the Sample database.  If you go through it using a different database, it will be somewhat the same but the 

results may vary. 

FINDING RECORDS IN THE REPORT FORM 

Quick name find. 

To find a record with last name beginning with W and first name beginning with H: 

From the report form, key in F8.  The quick name find form appears 

Key in W in the last name field, tab. Then go to the first name field and enter H. 

Hit the Enter key or the Find button, 

The report form will appear with the record for Hong Wang highlighted in the table and the red ellipse on lot 29 

To find the next record with that find criteria hit the F3 key.  The record for Hong Weng appears and lot 49 has the red ellipse. 

 

Continue to hit F3 for further records that fit the criteria. 

If at any time you wish to go to the lot form, hit F6and the currently selected lot will be displayed.  To return to the report form, hit F5. 

Find records with other find criteria. 

Find a record with age greater than 50: 

From the report form, key in Ctrl+F3.  The find form appears 

Key 50 in the Find field. 

In the column drop down box select Age. 

In the Match drop down box select More than 

Hit the Find button, 

Hit F3 for further records that fit the criteria. 

Select all records with select criteria. 

To find all veterans: 

From the report form, key in Ctrl+F3.  The find form appears 

In the find drop down box, drop down and click the Not empty option. 

In the column drop down box select Vet. 

Hit the Select from whole database ebutton, 

Only those records with something in the Vet field will be in the select table. 

Hit F3 for further records that fit the criteria. 

Redisplay all records into the select table. 

Menu Edit>Select All 

FINDING RECORDS/LOTS IN THE LOT FORM 

Finding records here use the same technique as for the report form except that the record is displayed and highlighted in the context of the lot form.  

You will not be able to do a Select from whole database here. 

 

Find a record with last name equal Hung: 

From the report form, key in Ctrl+F3.  The find form appears 

Key Hung in the Find field. 

In the column drop down box select Last name. 

In the Match drop down box select Exactly equal. 

Hit the Find button.  Lot 7 will be displayed with the record for Tong Hung highlighted. 

 

F3 still advances to the next record fitting the find criteria. 

F4 will advance you to the next lot which has a record fitting the find criteria 
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SORTING RECORDS 

To sort the select table into age order: 

Menu Edit>Sort brings up the sort form. 

Enter a 1 in the age field (If you want it in descending order enter 1d).  Hit the Sort All Button. 

The select table will appear with all the records in age sorted order. 

 

NOTE: If you hit the Sort Selected button instead of the Sort All button, only the records currently in the select table will be sorted. 

UPDATING RECORDS 

Record update. 

All updating of database records is done from the update form 

To update the record for Peng Mong in lot 5. 

In either the lot or report form, do menu Edit>Go to lot.   

An input box appears. 

Enter 5 in it and hit the Enter key. 

Lot 5 will be displayed in the lot form. 

Click on the line in the burial section that contains Peng Mong.  

The update form will appear. 

Tab to the grave id text box and change it to 3.  Hit the update button. 

A warning will appear letting you know that you changed the grave id. 

Hit the OK button. 

Note that the name moved from lot 10 to lot 3. 

Undo 

This will undo the last change you made. 

To undo the record update above; 

Do menu :Edit>Undo or Ctrl+Z. 

Note that the record reverts back to grave 3. 

The name moves back to grave 3 in the map as well. 

Record add 

To add a record for King Mong in lot 5. 

Go to lot 5 in the lot form. 

Click on the Peng Mong record in the grave id cell. 

The update form will appear with the cursor in the grave id field. 

Change it to 4. 

Tab to the first name column and change it to King. 

Hit the Add button. 

A warning will appear letting you know that you changed the grave id. 

Hit the OK button. 

A new record appears and it shows in grave 4 in the map.. 

 

Note:  If you click on the empty line at the end of either the owner or burial section, the update form will appear with all fields empty/  

You will only be allowed to do the Add button then. 

Record delete 

To delete the record for Peng Mong in lot 5. 

Go to lot 5 in the lot form. 

Click on the Peng Mong record in the grave id cell. 

The update form will appear. 

Hit the Delete button. 

The record is gone/ 
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PRINTING 

Printing the select table 

Select the records desired into the table. 

Sort them in the order desired. 

Hit Ctrl+P 

The Print select form appears. 

 

If the select report is not sorted in last/first name order, an Alert message appears telling you so.  Ignore this and hit OK 

 

If you wish to change any parameters, do so. See Help or F1 for details. 

Hit the Print button. 

The select report will be printed to your printer.. 

Printing the lot form 

Go to the lot form and display the desired lot. 

Hit Ctrl+P. 

A copy of the lot form will be sent to the printer. 

Printing maps 

See MAPS/WALL CHARTS section below. 
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MAPS/WALL CHARTS 

MAP print prevue form 

This window is used to prevue the cemetery map or parts thereof and, optionally, print them out.  It allows you to specify which parts to print as well 

as size and other options.   You get here from either the lot or report window by going to menu View>Map print prevue window: 
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Printing the cemetery map 

Go to the print prevue window via menu View>Map print prevue. 

The print prevue window appears with the cemetery shown with all lots. 

Experiment with the detail level options to see the differences, 

Click the show highlighted checkbox to see the map entities shaded if there are any items in the select table for that map entity. 

Hit the Print Preview button 

The Print setup form appears. 

Click the Landscape option and hit Enter 

The picture now shows what will be printed when you hit the Print Button.  It will be shown as the best fit for the currently selected 

printer. 

Click on the Size button. 

Change the height to 6 and hit OK.  It will now be a little smaller than the currently selected printer, 

Hit the Print button. 
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MISCELLANEOUS 

Making a new database 

From the report form enter Ctrl+N 

A message box appears asking you to enter a database name. 

Enter one and hit OK. 

The Cemetery info form appears. 

Change the cemetery name to what you would like 

If you wish, change the other fields.  

Hit OK. 

You will get a message saying that the database has been saved.  Just hit OK. 

You will get a message saying that you do not have a database key. Just hit OK. 

 

Note:  You will get this message every time you open your new database from now on.  Click on the Help button in the 

message box to find out how to make it go away, 

 

Your database is initialized with no records and the report form is displayed. 

The cemetery map will be a copy of the Sample database. 

Backing up your database. 

From the report form menu hit Database>Backup. 

The backup form will appear. 

Enter the drive on which you want the backup to be written. 

Hit OK 

The file will be written to that drive. 

You will get a confirmation message stating how it was saved. 

Restoring your database. 

You use this in case of disaster or if your backup copy is more up to date than your current database.  This is typical if you backup your dataset on 

one computer and restore it on another. 

From the report form menu hit Database>Restore. 

The restore form will appear. 

Enter the drive which contains your back up. 

Hit OK 

A list box will appear with the names of the databases which may be restored. 

Select the one you want and hit OK. 

 

If the one you select is not the one you are currently in, you will get a message box telling you so.  If you really want the new 

one just hit OK.  The current database you are on will then be closed before restoring and opening the new one. 

 

The database will be restored and a message verification box will be displayed. 

Hit OK. 

The Opening form for the restored database will be displayed.. 
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MAKING A SHORTCUT 

 
There are several ways of putting a shortcut to get to buuthill on your desktop.  This will allow you to click on it bypassing the first 2 steps above.  I 

will explain one here. 

 

Right click any place on the empty desktop.  A menu will appear that will give you choices.   Select the “New” option, which will show another 

menu on which you should select the “shortcut” option. 

 

Type in “C:\Program files (x86)\buuthill\buuthill.exe”.  (Don’t put in the “ characters and note that the slashes are reversed).  

On earlier versions of windows there is no “(x86)” file.   In that case leave the “(x86)” out of the name. 

 

 You can do the same thing by selecting the “browse” button, going to the C directory, then the program files directory, then the buuthill directory 

and then selecting the buuthill.exe file or application.    

 

Hit the “Next” button and on the next screen, hit the “Finish” button. 

 

Note:  This may not be the exact sequence on all computers.  This is the sequence on Windows 10  and will be quite similar on all others. 

 

OPENING A DATABASE WITH THE SHORTCUT 

 
The following may be done to cause the database to be opened directly when going into the program rather than making you pick it when opening the 

program. 

 

Right click on the desktops Buuthill icon, which you just made” and select the “properties” option.  You will see a text box called “Target” with the 

following text in it: 

 "C:\Program Files (x86)\BUUTHILL\buuthill.exe" 

 

Add text to this to make it read: 

 "C:\Program Files Files (x86)\BUUTHILL\buuthill.exe" /fil c:\program files Files (x86)\buuthill\sample.cmf 

 

Note that there is a space between exe” and /fil, between /fil and c: and between program and files.   Also note the /fil has a forward slash and the rest 

have reverse slashes. 

 

Hit “ok” and now hitting the desktop icon brings the program up with the database open. 

 

When you get your own database, you may change sample” to whatever that is. 
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